• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Dodge, Jeep and RAM Forum dedicated to FCA owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the SRT Forum today!


New transmission installation questions

fumanchu182

3000 Posts Club
Vendor
Premium Account
U.S. Navy Veteran
Donating Member
9 Second Best E/T
HFCOTM
Member ID
#2366
Messages
3,639
Reactions
8,884
Likes
302
City
Pasadena
State
MD
Country
United States
Vehicle
2015 Challenger SRT Hellcat
#1
So I think I am out of my element here. Last night we installed my Pure transmission. We got it all buttoned up, did the fill procedure and got it ready for driving. We are following the guidance here:

https://www.puredrivetrainsolutions.com/break-in-process

Mike's Wi-Tech couldn't locate a relearn procedure to run. We switched over to HP Tuners. Cleared all TCM and PCM DTCs. Reset all adaptives and then did the Fast Relearn procedure. Mike said it went through all the gears. Drove it home and it went into limp mode. Would not get out of sixth gear. Stopped in a parking lot let the car reset after turning it off. Went into limp again and got it home. Today, reset all adaptives, reset all the DTCs and attempted to do the Slow Relearn this time. HP Tuners gave me this error:
image.png
Attempted to do the Fast Relearn and nothing, same error.

Reset everything again and just put into reverse, backed it out of the garage and drove it. Went right into limp mode again. I'm kind of at my wits end with this car. I don't know what to do and I can't put any more money into it. I have reached out to Pure and hopefully they will get back to me soon. But if anyone has advice please don't hesitate to chime in. Tune, log and error codes are attached.
 


Attachments

hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#2
If it’s going into limp
What fault codes are you getting
 


OP
fumanchu182

fumanchu182

3000 Posts Club
Vendor
Premium Account
U.S. Navy Veteran
Donating Member
9 Second Best E/T
HFCOTM
Member ID
#2366
Messages
3,639
Reactions
8,884
Likes
302
City
Pasadena
State
MD
Country
United States
Vehicle
2015 Challenger SRT Hellcat
Thread Starter #3
If it’s going into limp
What fault codes are you getting
they are attached in the text file:
0x7E8: P0430 - Catalyst System Efficiency Below Threshold (Bank 2) (Permanent)
0x7E8: P1206 (SES, Pending, Current, Permanent)
0x7E8: P2096 - Post Catalyst Fuel Trim Sys Too Lean Bank1 (Pending, Permanent)
0x7E8: P2098 - Post Catalyst Fuel Trim Sys Too Lean Bank2 (Pending, Permanent)
0x7E8: U0140 - Lost Communication With Body Control Module (Permanent)
0x7E9: P0716 - Turbine/Input Shaft Speed Sensor A Circuit Range/Performance (SES, Pending, Current)
0x7E9: P0732 - Gear 2 Incorrect Ratio (SES, Current)
0x7E9: P1D90 (SES, Pending, Current, Permanent)
0x7E9: P1D95 (Permanent)
0x7E9: P1DF3 (Permanent)
0x7E9: U0001 - High Speed CAN Communication Bus (Permanent)

Freeze Frame: 0
DTC: P0732 - Gear 2 Incorrect Ratio
Calculated Engine Load: 12.5490196078431 %
Engine Coolant Temp: 88 °C
Engine RPM: 3496 rpm
Vehicle Speed: 40 km/h
Control Module Voltage: 13 V
Accelerator Position D: 19.6078431372549 %


Freeze Frame: 0
DTC: P2098 - Post Catalyst Fuel Trim System Too Lean Bank 2
Fuel System Status: 02 02
Calculated Engine Load: 22.3529411764706 %
Engine Coolant Temp: 83 °C
Short Term Fuel Trim Bank 1: -5.46875 %
Long Term Fuel Trim Bank 1: 0 %
Short Term Fuel Trim Bank 2: -1.5625 %
Long Term Fuel Trim Bank 2: -1.5625 %
Fuel Pressure: 453.000472515733 kPa
Intake Manifold Absolute Pressure: 40 kPa
Engine RPM: 699 rpm
Vehicle Speed: 2 km/h
Timing Advance: 8 °
Intake Air Temp: 53 °C
Throttle Position: 11.3725490196078 %
Run Time Since Engine Start: 124 s
Commanded EVAP Purge: 8.23529411764706 %
Fuel Level Input: 46.6666666666667 %
EVAP System Vapor Pressure: 15937 kPa
Barometric Pressure: 101 kPa
Control Module Voltage: 13 V
Absolute Load: 22.7450980392157 %
Commanded EQ Ratio: 1
Relative Throttle Position: 1.96078431372549 %
Ambient Air Temp: 38 °C
Absolute Throttle Position B: 11.7647058823529 %
Accelerator Position D: 8.23529411764706 %
Accelerator Position E: 4.31372549019608 %
Commanded Throttle Actuator: 1.96078431372549 %
Fuel Type: 01
68: 07 5B 60 5F 00 00 00
77: 0A 00 5D 00 5E
 


hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#4
Try to clear log and then add trans turbine to see if it’s reading it should read engine rpm in park and go to zero in drive at a stop
 


hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#5
Or just call me I’ll try to help
901-568-3001
 


zhc

Active Member
Founding Member
7 Second Best E/T
Member ID
#1019
Messages
386
Reactions
1,338
Likes
117
City
Houston
State
TX
Country
United States
Vehicle
2016 Dodge Charger Hellcat
#6
So, to clarify. It drove home fine and then at the end it didn't?

Does it go limp mode in reverse?

Does it go limp in 1st gear moving forward (manual mode)

Does it go limp when it tries to shift to 2nd gear?

Based on sequence of events and the codes you're getting, it seems mechanical to me, maybe an issue with e clutch or e drum.
 


Last edited:

Jack_Toepfer

3000 Posts Club
Founding Member
Premium Account
Donating Member
Member ID
#966
Messages
3,448
Reactions
6,947
Likes
252
City
Buffalo
State
NY
Country
United States
Vehicle
21 F150 Platinum Whippled
#7
Never heard of these “Pure” guys. Anyone have any history with them?
 


hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#8
The P0716 concerns me , if it’s reading then with the rest of the faults it definitely looks to be an internal issue, I’m assuming you had your trans rebuilt and kept your original tcm if so and you didn’t have these faults before then I would verify fluid level one more time then submit a claim with pure drivetrain, unfortunately it sounds like it will be coming back out 😞
 


Idoru99

Active Member
Premium Account
U.S. Navy Veteran
Donating Member
Member ID
#4871
Messages
305
Reactions
577
Likes
67
City
Springfield
State
VA
Country
United States
Vehicle
2021 Challenger Redeye WB
#9
Never heard of these “Pure” guys. Anyone have any history with them?
They're one of the MSHS Sponsors, haven't heard much else about them
 


zhc

Active Member
Founding Member
7 Second Best E/T
Member ID
#1019
Messages
386
Reactions
1,338
Likes
117
City
Houston
State
TX
Country
United States
Vehicle
2016 Dodge Charger Hellcat
#10
The P0716 concerns me , if it’s reading then with the rest of the faults it definitely looks to be an internal issue, I’m assuming you had your trans rebuilt and kept your original tcm if so and you didn’t have these faults before then I would verify fluid level one more time then submit a claim with pure drivetrain, unfortunately it sounds like it will be coming back out 😞
I concur, shaft speed sensor issue potentially as well.

Nice to see you posting again @hellno!
 


OP
fumanchu182

fumanchu182

3000 Posts Club
Vendor
Premium Account
U.S. Navy Veteran
Donating Member
9 Second Best E/T
HFCOTM
Member ID
#2366
Messages
3,639
Reactions
8,884
Likes
302
City
Pasadena
State
MD
Country
United States
Vehicle
2015 Challenger SRT Hellcat
Thread Starter #11
Try to clear log and then add trans turbine to see if it’s reading it should read engine rpm in park and go to zero in drive at a stop
Or just call me I’ll try to help
901-568-3001
thank you so much for the offer, currently im stuck at work and my boss is going to kill me cause i blew 4 hours this morning testing

So, to clarify. It drove home fine and then at the end it didn't?

Does it go limp mode in reverse?

Does it go limp in 1st gear moving forward (manual mode)

Does it go limp when it tries to shift to 2nd gear?

Based on sequence of events and the codes you're getting, it seems mechanical to me, maybe an issue with e clutch or e drum.
When driving home I noticed it wasnt coming out of sixth gear, it also went into limp mode in reverse. Ive noticed it wont go past second sometimes, but dont know if thats limp mode.

The P0716 concerns me , if it’s reading then with the rest of the faults it definitely looks to be an internal issue, I’m assuming you had your trans rebuilt and kept your original tcm if so and you didn’t have these faults before then I would verify fluid level one more time then submit a claim with pure drivetrain, unfortunately it sounds like it will be coming back out 😞
That code is a new code. Mike when he put it in said it took everything and then when warmes up came out the fill hole as expected.
I concur, shaft speed sensor issue potentially as well
Before sending it off I told Pure I was having these issues as well they have my logs and tune from that error code.
 


hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#12
The P0716 even thought it say circuit in the definition, the range performance is generally the key words you look for ,it’s noticing the the input and output are not within the parameters it should be , that’s how it sets the P0732 fault , it basically can see the slippage in the trans but I would imagine pure drivetrain will get it resolved in a timely manner
 


hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#13
500 mile break in
Shit I quick learn and beat the hell out of it 😂
 


Attachments

OP
fumanchu182

fumanchu182

3000 Posts Club
Vendor
Premium Account
U.S. Navy Veteran
Donating Member
9 Second Best E/T
HFCOTM
Member ID
#2366
Messages
3,639
Reactions
8,884
Likes
302
City
Pasadena
State
MD
Country
United States
Vehicle
2015 Challenger SRT Hellcat
Thread Starter #14
Spoke with pure again today, was told there were two, one ounce quarts and the two gallon container. Evidence A: crate opened upon delivery.
8C5D9BFE-6561-4BC0-99BD-356509972BF2.jpeg
notice no two additional quarts.
I sent them the current tune and a log, they claim the TCM file was not stock, okay Ill play ball. Loaded my stock TCM file on. Same thing. Evidence B: my current tune and log file.

I don't know what to do at this point. Mike is coming over after work with his witech and see what he can do.
 


Attachments

hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#15
So they don’t allow the trans tune to be modified?
And you said you verified fluid level regardless how many quarts they sent , that why I like to get converter with mine so I can prefill it and I over fill it on purpose so all that needs to be done Is drain some out after test drive and resetting adapts and quick learn , but you’d be surprised how many do not get them filled correctly
 


hellno

3000 Posts Club
8 Second Best E/T
HFCOTM
Member ID
#1308
Messages
3,322
Reactions
5,795
Likes
302
City
memphis
State
TN
Country
United States
Vehicle
2016 challenger hellcat
#16
Curious how many qts did you put in it
 


Linda's Hell Cat

4000 Posts Club
Staff Team
Founding Member
Donating Member
9 Second Best E/T
Member ID
#972
Messages
4,795
Reactions
33,707
Likes
252
City
Bucks County
State
PA
Country
United States
Vehicle
2015 Charger Hellcat
#17
So I think I am out of my element here. Last night we installed my Pure transmission. We got it all buttoned up, did the fill procedure and got it ready for driving. We are following the guidance here:

https://www.puredrivetrainsolutions.com/break-in-process

Mike's Wi-Tech couldn't locate a relearn procedure to run. We switched over to HP Tuners. Cleared all TCM and PCM DTCs. Reset all adaptives and then did the Fast Relearn procedure. Mike said it went through all the gears. Drove it home and it went into limp mode. Would not get out of sixth gear. Stopped in a parking lot let the car reset after turning it off. Went into limp again and got it home. Today, reset all adaptives, reset all the DTCs and attempted to do the Slow Relearn this time. HP Tuners gave me this error:
View attachment 82077
Attempted to do the Fast Relearn and nothing, same error.

Reset everything again and just put into reverse, backed it out of the garage and drove it. Went right into limp mode again. I'm kind of at my wits end with this car. I don't know what to do and I can't put any more money into it. I have reached out to Pure and hopefully they will get back to me soon. But if anyone has advice please don't hesitate to chime in. Tune, log and error codes are attached.
I don't Know much at all except ask help from @jonx96 and see what he says!
 


OP
fumanchu182

fumanchu182

3000 Posts Club
Vendor
Premium Account
U.S. Navy Veteran
Donating Member
9 Second Best E/T
HFCOTM
Member ID
#2366
Messages
3,639
Reactions
8,884
Likes
302
City
Pasadena
State
MD
Country
United States
Vehicle
2015 Challenger SRT Hellcat
Thread Starter #18
Curious how many qts did you put in it
The 2.5 gallons provided which would be ten quarts. Mike did the fill procedure to Mopar specs. Heat it up, open the fill cap, if its flowing out it is good if it isn’t then more fluid required.

I don't Know much at all except ask help from @jonx96 and see what he says!
I spoke with Jon, nothing in the car is at fault. This evening Mike even came to my house we reviewed what could be at fault. We went through everything. To start we went amd rewrote my PCM and TCM from the WiTech, this provided a set of stock calibrations in the car. From there we the overlaid my PCM calibration cause E85. At this point we started the car to let it idle and get up to temp. We did the slow relearn procedure from HP Tuners. It would go through gears 1 and 2, then when getting to gear 3 it would error out of the procedure. It did this three times.

At this point Mike and I are scratching our heads. We have not rules out the following.
  • Air pocket
  • The two additional quarts count, atf vs zf
  • Physical issue with trans
  • Bad tcm
  • Bad valvebody
  • Bad pcm
I have one TCM, one PCM but have no clue where to buy a valvebody in good condition. I sent an email to Pure with all this information and await their response. To their credit they are helping us. In a similar experience Mike installed a transmission from a Mopar builder that exhibited the same, turns out it was a blown input shaft seal.
 


zhc

Active Member
Founding Member
7 Second Best E/T
Member ID
#1019
Messages
386
Reactions
1,338
Likes
117
City
Houston
State
TX
Country
United States
Vehicle
2016 Dodge Charger Hellcat
#19
Only 8 quarts was put in? That seems... short by a lot if the trans was completely empty. Invalid question, striking out.

Were similar procedures followed when fluid level was checked? See attached.
 


Attachments

Last edited:
OP
fumanchu182

fumanchu182

3000 Posts Club
Vendor
Premium Account
U.S. Navy Veteran
Donating Member
9 Second Best E/T
HFCOTM
Member ID
#2366
Messages
3,639
Reactions
8,884
Likes
302
City
Pasadena
State
MD
Country
United States
Vehicle
2015 Challenger SRT Hellcat
Thread Starter #20
Only 8 quarts was put in? That seems... short by a lot if the trans was completely empty.

Were similar procedures followed when fluid level was checked? See attached.
2.5 Gallons is 10 quarts? Is my math wrong?
 




Top